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I love pixels! They’re the building blocks of all the visual design we do
here at ustwo™, but are so often relegated to a mere afterthought in
the excitement of working with colours and styles. The aim of this Pixel
Perfect Precision™ handbook is to bring them back to the forefront of
our thoughts, to make sure we get the simple things right before
moving onto the detail.
Why is this important though? Isn’t it just wasting time worrying about
every last pixel on the page? Like a lot of things in life, when
something’s done right it should become invisible to you, but when it’s
done badly it becomes an annoyance. Blurred edges, objects that jump
in position between pages, and colour mismatches are just a few things
that a user will notice and become distracted by if your designs aren’t

Introduction

done properly, leaving them with a poor impression of the product.
For this latest release we’ve separated the Photoshop-specific advice
from the core principles (and expanded on them) to make the
handbook more useful across a range of disciplines; we know that there
are lots of interaction designers and developers out there who want to
learn about this area of design, so we’ve made the handbook a more
relevant resource for you. There’s also a completely revised section on
Accessibility, an area we feel needed the PPP™ treatment to give you
the essentials you need to know in an easy-to-understand way.
Gyppsy xx
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The Essentials
This first section covers a lot of core principles and topics that apply to
all digital design and its relevant tools. For seasoned designers it can act
as a refresher for things to look out for and consider, and for those
starting out it offers a quick start guide to some of the processes and
thinking that we apply to projects.

ustwo™ studios 2013 / PPP™

3

Pixel Perfect
Principles

Naughty
Sharp Edges
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Nice

Straight edges should be on-pixel and sharp –
blurred edges are a no-no!
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Naughty
Alignment &
Spacing
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x

Nice

Once you’ve mastered the art of getting
everything sharp the next step in your journey
towards pixel perfection is to get the
alignment and spacing right.
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Consistency

Alignment of objects across multiple screens is

The best way of doing this is to set yourself up

just as important. Margins and placement of

a grid, which will define a structure that can

common items such as title bars, back

be followed throughout your screens.

buttons, and footers should be the same
throughout the interface to prevent objects
jumping around.
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Environment

Environment refers not only to the platform

are almost always used indoors, and are

you’re designing for, but also how it will be

operated via remote. This in turn means

operated and the physical space that it will be

different considerations for things like text

used in. For example, TVs have a completely

size, colours, and contrast within the interface.

different set of variables to mobile phones –
they are viewed from a much greater distance,
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Random Text
Squeezed in to Fit
Object Description that runs off the edge o
Object Description that runs off the edge o
Object Description that runs off the edge o
Object Description that runs off the edge o
Object Description that runs off the edge o

Title
Object
Description
Object
Description

Object Description that runs off the edge o
Object Description that runs off the edge o
Object Description that runs off the edge o

Object
Description

Object Description that runs off the edge o
Object Description that runs off the edge o
Object Description that runs off the edge o

Naughty
Accessibility

Object
Description

Nice

Accessibility is a broad topic, being relevant to

accessible for those with conditions such as

every one of your users – not just those with

colour blindness and dyslexia. See the

some kind of disability. Good practice such as

Accessibility chapter for more information.

ease of use and clarity are a given and go a
long way in this area, but there are also steps
you can take to make your work more
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Lorem ipsum dolor sit
amet, consectetur
adipisicing elit, sed do
eiusmod tempor incididunt
ut labore et dolore magna
aliqua. Ut enim ad minim
veniam, quis nostrud
exercitation ullamco laboris
nisi ut aliquip ex ea
commodo consequat.
Duis aute irure dolor in
reprehenderit in voluptate
velit esse cillum dolore eu

Affordance
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Affordance is an object’s ability to convey its

This technique can also be used in digital

function through sensory means, for example

design to hint at how objects should be

by being slightly raised a button suggests that

interacted with: commonly used affordances

you press it; by being the right size and

include buttons which are given depth like in

position for a hand a door handle suggests

the real world, and text which flows off the

that you pull it.

page so it looks like it scrolls.
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Naughty
Colour & Shape

Nice

Some colours and shapes have become

to infer good, likewise red and crosses bad, but

synonymous with certain functions and

by jumbling the two up you create a mixed

messages within interface design. Be mindful

message. Similarly, yellow and triangles are

of these, as mixing them up can cause

often associated with warnings, blue and

confusion for the user if they’re expecting the

circles with information.

opposite. Green and ticks are commonly used
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11

Title
Object

Description
Object

Description
Object

Description
Object

Description

Naughty
Visual Hierarchy

Title
Object
Description
Object
Description
Object
Description
Object
Description

Nice

Layout, colours and typography have a huge

contrast and large, bold type, or push items

influence on how information is seen, and

back with lower contrast and smaller, lighter

what the eye is drawn to. Think about what

type weights. Culture also plays a part: for

you want the user to look at on the page, and

example Westerners will naturally start near

in what order, then start designing around

the top of a screen as that’s the way we read.

that hierarchy. Grab attention with high

ustwo™ studios 2013 / PPP™
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Lorem ipsum dolor sit amet,
consectetur adipisicing elit, sed do
eiusmod tempor incididunt ut labore et
dolore magna aliqua. Ut enim ad
minim veniam, quis nostrud
exercitation ullamco laboris nisi ut
aliquip ex ea commodo consequat. Duis
aute irure dolor in reprehenderit in
voluptate velit esse cillum dolore eu
fugiat nulla pariatur. Excepteur sint
occaecat cupidatat non proident, sunt
in culpa qui officia deserunt mollit anim
id est laborum. Lorem ipsum dolor sit
amet, consectetur adipisicing elit, sed
do eiusmod tempor incididunt ut labore
et dolore magna aliqua. Ut enim ad
minim veniam, quis nostrud
exercitation ullamco laboris nisi ut
aliquip ex ea commodo consequat. Duis
aute irure dolor in reprehenderit in
voluptate velit esse cillum dolore eu
fugiat nulla pariatur. Excepteur sint
occaecat cupidatat non proident, sunt
in culpa qui officia deserunt mollit anim
id est laborum. Lorem ipsum dolor sit

Naughty
Typography

Lorem ipsum dolor sit
amet, consectetur
adipisicing elit, sed do
eiusmod tempor incididunt
ut labore et dolore magna
aliqua. Ut enim ad minim
veniam, quis nostrud
exercitation ullamco laboris
nisi ut aliquip ex ea
commodo consequat. Duis
aute irure dolor in

Nice

Typography is an often overlooked part of the

squinting? Is there enough leading and are the

digital experience, but since most information

line lengths short enough to make reading

is conveyed through text it’s one of the most

comfortable? Don’t just accept the default

important parts of a design. The same basic

font settings in your design environment –

principles as for any other medium apply – is it

treat type with the respect it deserves!

a comfortable size for reading without

ustwo™ studios 2013 / PPP™
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Testing
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This step has a close link to Environment in

mouse and keyboard to other types of input.

that you may know a lot about the platform

There are a wide range of live previewing tools

you’re designing for, but nothing beats testing

available these days that will take a design

on actual device(s). Screen resolution and

from your computer and place it directly on

technology can vary dramatically compared to

your device, updating in real time as you apply

your computer, not to mention switching from

changes. Make sure to use them!
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Project
Design
Screen.psd
Assets
Rectangle.png
Square Blue.png
Square Green.png
Square Orange.png
Square Pink.png

Organisation

No man is an island, and most of the time

around, and a logically named set of assets

your files won’t be either! Good organisation is

will make a developer very happy.

essential when sharing designs as it saves a
lot of time for other people. Well ordered files
and layers mean other designers can jump
straight into your work and find their way

ustwo™ studios 2013 / PPP™
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Take a Break

It’s very easy to get completely consumed in

minutes: after coming back the solution to a

the design process, but sometimes it pays to

design problem might be staring you right in

take a break – not just for health reasons, but

the face, or you might spot a flaw that had

also the different perspective a refreshed set

previously gone unnoticed!

of eyes can bring. Go and make yourself a
brew, or wander somewhere else for a few

ustwo™ studios 2013 / PPP™
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Pixel Perfect
Details

0°

H

270°

90°

180°

0%

0%

Colour Model

S

Hue

352

352

352

352

Saturation

78

20

39

78

Brightness

89

95

95

55

Red

228

243

242

140

Green

50

194

148

31

Blue

72

201

160

49

100%

B

100%

HSB FTW! Have a go at using HSB as a colour

and Brightness (B) changed to create the

model when creating a palette: once you get

variations. See how much more sense the

your head around it you’ll see it’s a really

numbers make in HSB compared to RGB?

efficient way to create shades of a base
colour. In the example the Hue (H) value has
been kept the same, then the Saturation (S)

ustwo™ studios 2013 / PPP™
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Colour Profile

Yes

No

Code

Naughty
Colour
Management
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Nice

Colour Management makes a lot of sense in a

unmanaged code (specifying the same

print environment, but for digital it can often

original colour) there can be a mismatch.

create more problems than it solves. The main

Much better to ignore colour management

issue is that it’s not available throughout the

altogether, and instead test on the device –

development process – you can manage your

unlike print this takes a matter of seconds and

assets, but when they’re mixed with

costs nothing!
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Åy

WWWW

Max. Height

Max. Width

Text Height &
Width

A great way to check the maximum height
that a block of text can be is to use the Åy
characters. If a design needs to fit a minimum
number of characters then use a series of
capital Ws to judge the space needed – if they
fit then anything else will too.
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Settings
Einstellungen
Configurações
Text Length

If you’re working on a design that will be used

translations of Settings: an increase of up to

with other languages it’s also worth

75% in length.

considering how long your text could be when
translated. The example above shows what
happens with the German and Portuguese

ustwo™ studios 2013 / PPP™
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Align Text

Align Text

Align Text

Align Text

Align Text

Align Text

ABC123

ABC123

ABC123

Cap Height & Descender

x-height

Cap Height & x-height

Aligning Text on
Buttons

Featured above are three ways to vertically

lowercase text or caps/numbers. The most

aligning text on buttons. There are a few

important thing though is to make sure that

variables which can affect which method is

once you pick a rule you use it on every button

the best, such as the typeface used (for

– consistency is king!

example the cap height to x-height ratio can
vary) or whether you’re using upper- and

ustwo™ studios 2013 / PPP™
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Aligning Text with
Objects

Align Text

Align Text

Align Text

Align Text

Naughty

Nice

Try to vertically align text using the x-height,
ignoring ascenders and descenders. This
means that dynamic text, which could contain
any combination of characters, will always
look correctly aligned.
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Button

Button

Button

Outer = Inner

Inner Scaled

Outer = Inner + Border Width

Borders & Corner
Radii

You’ll often want to create some kind of

the outer radii, scaling the original shape in

border for your components, in which case

size, and adding the border and original inner

how do you work out the outer radius when

radius together. The latter is by far the best

you’ve already set the inner (or vice-versa)?

method, resulting in consistent outlines that

There are a few methods, the most common

don’t thicken at the corners like the other two.

being shown above: matching the inner and

ustwo™ studios 2013 / PPP™

24

Borders & Corner
Radii
Filleting
ustwo™ studios 2012 / PPP™

Button

Button

Inner = Outer - Border Width

Filleted

If you use the preferred method, but start

mathematically “incorrect” it may look better

from the outer radius and work your way in by

from a visual perspective. In the engineering

subtracting the border width, you may end up

world this process is known as filleting, with

with inner corners that are completely square.

each individual corner called a fillet. For an in-

In those situations it may be worth adding a

depth article on borders and corner radii check

small radius to those corners: even though it is

out this article from Radesign.
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100%

100%

Naughty
Equilateral Triangles

86.6%

100%

Nice

A lot of graphics applications won’t give you
an equilateral triangle when you draw a threesided polygon, instead they’ll make the width
and height the same. To quickly convert to an
equilateral scale the height (with one face
horizontal) by 86.6%.

ustwo™ studios 2013 / PPP™
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Project

Project

Screen_1.psd
Screen_2.psd

Screen_130401_r01.psd

Screen_FINAL.psd

Screen_130402_r01.psd

Screen_FINAL_FINAL.psd

Screen_130402_r02.psd

Screen_FINAL_FINAL_2.psd

Screen_130402_r03.psd

Screen_FINAL_FINAL_3.psd

Screen_130403_r01.psd

Screen_Latest_1.psd

Screen_130403_r02.psd

Screen_Latest_2.psd

Naughty
Version Control

ustwo™ studios 2013 / PPP™

Archive

Screen.psd

Nice

Although there are now a multitude of version

is kept at the top level of the working folder. At

control systems available for designers to use

the start of the day, and at other key points,

more often than not we still end up saving

that file will be duplicated, placed in the

files manually. To make it easier to keep track

Archive folder, and given a filename based on

of files and revisions we use a system like that

the date (YYMMDD so it shows in the right

shown above. The most recent file, Screen.psd,

order) and revision number. Tidy!
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Naming Systems

Coming up with a standard naming system for

Then add the unique identifier, so buttons on

your assets and components on a project

the home screen which create and delete

eases the transition from design to

documents would be called:

development and will make everyone happy!
Although different people and studios will

btn_home_new btn_home_delete

have their own individual way of doing things
a good approach is to base your naming on a

The final part is to add the state if it’s

hierarchical system, which starts off with a

interactive or changes at any point:

broad identification of the component and
then progressively adds more levels of detail.

btn_home_new_default

So you might use a structure like this:

btn_home_new_highlighted

type_location_identifier_state

As an aside the system shown here uses
lowercase letters and underscores instead of

The type refers to what category the

spaces in the names, which is our usual

component belongs to, such as:

choice, but another method is CamelCase,
which uses no spaces and instead capital

bg (background) btn (button) icn (icon)

letters to define each part of the structure:

The next step is to add the screen or location

BtnHomeNewDefault BtnHomeNewSelected

where this component appears:
The final, and most important, point to make
bg_help btn_home icn_global

is that the best way to go about all this is to
speak to the developer you’re working with

ustwo™ studios 2013 / PPP™

(global refers to components that appear

and see which system they like to use, and

across multiple screens or sections)

then adapt what you’re doing to that!
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Naming Systems
Example
icn_global_signal_full
btn_global_menu_default

icn_global_battery_full

Title

btn_home_play_pink_default

Object
Description

btn_home_play_orange_default

Object
Description

btn_home_play_green_default

Object
Description

btn_home_play_blue_default

Object
Description

ustwo™ studios 2013 / PPP™

btn_global_search_default

bg_home_description
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Accessibility

“If I make my design
accessible won’t it
look rubbish?”
Accessibility

Accessibility isn’t about creating compromised

designs comply to standards: like pixel perfect

products for those with disabilities, but instead

precision, if you make these principles part of

means good, inclusive design made for

your design-thinking and build them in from

everyone. You don’t need to make huge

the start then you’ll find accessibility takes

sacrifices in terms of visual appeal, or spend

very little time at all.

lots of extra time and money making your

ustwo™ studios 2013 / PPP™
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Types of
Impairment

ustwo™ studios 2013 / PPP™

Around 10% of the UK population have some

other three senses. You shouldn’t rely on just

form of disability, which is a large number of

one of them to make your product or feature

potential users to consider. There are four

usable, but instead allow multiple forms of

main types of impairment that will commonly

interaction and communication where

affect digital projects – sight, hearing, touch

possible – for example enabling text-to-

and cognitive i.e. the ability to process those

speech functions for visually impaired users.
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A Title That Is Far Too
Long For This Screen…
Object Description that runs off the edge o
Lorem ipsum dolor sit amet, consectetur
adipisicing elit, sed do eiusmod tempor
incididunt ut labore et dolore magna aliqua.
Ut enim ad minim veniam, quis nostrud
exercitation ullamco.
Object Description that runs off the edge o
Lorem ipsum dolor sit amet, consectetur
adipisicing elit, sed do eiusmod tempor
incididunt ut labore et dolore magna aliqua.
Ut enim ad minim veniam, quis nostrud
exercitation ullamco.
Object Description that runs off the edge o
Lorem ipsum dolor sit amet, consectetur
adipisicing elit, sed do eiusmod tempor

Title

Title

Object
Description

Object
Description

Object
Description

amet, consectetur
adipisicing elit, sed do
eiusmod tempor incididunt

Object
Description

ut labore et dolore magna
aliqua. Ut enim ad minim
veniam, quis nostrud

Object
Description

Naughty
Clarity

Lorem ipsum dolor sit

exercitation ullamco.

Nice
Keep your designs as clear and concise as they

important to consider adapting your content

can be to avoid overloading the user with too

so that it’s suitable for mobile devices – for

much content. You can do this by showing

example keeping image sizes small for those

information which is relevant to the context of

on data connections.

the user, and then use progressive disclosure
to reveal more details as they require. It is also

ustwo™ studios 2013 / PPP™
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Lorem ipsum dolor sit amet, consectetur
Lorem ipsum dolor sit amet, consectetur

adipisicing elit, sed do eiusmod tempor

adipisicing elit, sed do eiusmod tempor

incididunt ut labore et dolore magna

incididunt ut labore et dolore magna

aliqua.

aliqua. Ut enim ad minim veniam, quis
nostrud exercitation ullamco laboris nisi ut
aliquip ex ea commodo consequat. Duis
aute irure dolor in reprehenderit in

Ut enim ad minim veniam, quis nostrud
exercitation ullamco laboris nisi ut aliquip
ex ea commodo consequat.

voluptate velit esse cillum dolore eu fugiat

Duis aute irure dolor in reprehenderit in

nulla pariatur. Excepteur sint occaecat

voluptate velit esse cillum dolore eu fugiat

cupidatat non proident, sunt in culpa qui

nulla pariatur. Excepteur sint occaecat

officia deserunt mollit anim id est laborum.

cupidatat non proident, sunt in culpa qui
officia deserunt mollit anim id est laborum.

Naughty
Clarity
Break Up Large
Blocks of Text
ustwo™ studios 2012 / PPP™

Nice

Break up large blocks of text so they’re easier
to digest and keep track of. Use somewhere
around 5 lines as a maximum and you’ll not
go far wrong!
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1. Pink – Lorem ipsum dolor sit amet,
consectetur adipiscing elit. Fusce

1.

Pink

2.

Orange

3.

Green

4.

Blue

pellentesque vehicula elit sed tincidunt.
Nam bibendum tempus tellus ac interdum.
2. Orange – Lorem ipsum dolor sit amet,
consectetur adipiscing elit. Sed fermentum
sodales orci. Class aptent taciti sociosqu ad
litora torquent per conubia nostra, per
inceptos himenaeos. 3. Green –
Pellentesque a nibh nibh, vel dictum risus.
4. Blue – Nunc congue vestibulum nibh non
sollicitudin. Donec eget metus leo.

Naughty
Clarity
Text to Diagrams

Nice

Some users, such as dyslexics, can have poor
organisational skills so consider breaking down
long paragraphs of text into lists or diagrams,
which help them by presenting the
information in smaller, ordered chunks.

ustwo™ studios 2012 / PPP™
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PPP

Naughty
Clarity
Abbreviations

PPP
(Pixel Perfect
Precision)

Nice

If you’re using abbreviations make sure to
include their expansion when they first
appear. Better still try to avoid them
altogether, as remembering what they stand
for can prove difficult for some users.

ustwo™ studios 2012 / PPP™
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OS

App

App

Title
Subtitle

Object
Description

Object
Description

Lorem ipsum dolor sit

Object
Description

amet, consectetur
adipisicing elit, sed do
eiusmod tempor
incididunt ut labore et

quis nostrud exercitation

Consistency

ustwo™ studios 2013 / PPP™

amet, consectetur
adipisicing elit, sed do

Object
Description

dolore magna aliqua. Ut
enim ad minim veniam,

Lorem ipsum dolor sit

eiusmod tempor
incididunt ut labore et
dolore magna aliqua. Ut

Object
Description

enim ad minim veniam,
quis nostrud exercitation

Your designs should maintain consistency

patterns from the host operating system – this

across a number of levels – for example their

will mean that the user can predict how the

styling, navigation, typography, and use of

product will behave based on their

language. Interface elements should behave

experiences with other apps. Most major

in a standard way throughout the app, and

devices have guidelines for their design and

also where possible follow any conventions or

interaction patterns.
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Title

Title

Object
Description

Object
Description

Object
Description

Lorem ipsum dolor sit
amet, consectetur

Title
Object
Search results
Object
Description

adipisicing elit, sed do
Object
Description

eiusmod tempor incididunt
ut labore et dolore magna

Object
Description

aliqua. Ut enim ad minim
Object
Description

Navigation

ustwo™ studios 2013 / PPP™

veniam, quis nostrud
exercitation ullamco.

Object
Description

Following on from the previous point about

across all screens, using the same styles and

consistency, navigation should follow the

labels. This also applies to other parts of the

same principle as it will help the user get

interface, for example if a button initiates a

around your app without feeling lost.

certain action in one part of the app then it

Elements that help the user move through the

should also perform the same action if

app should be positioned in the same place

activated elsewhere.
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Title
Lorem ipsum dolor sit
amet, consectetur

Title
Some really useful
information here!

adipisicing elit, sed do
eiusmod tempor incididunt
ut labore et dolore magna
aliqua. Ut enim ad minim
veniam, quis nostrud
exercitation ullamco.
laboris nisi ut aliquip ex ea
commodo consequat.

Lorem ipsum dolor sit
amet, consectetur
adipisicing elit, sed do
eiusmod tempor incididunt
ut labore et dolore magna
aliqua. Ut enim ad minim
veniam, quis nostrud
exercitation ullamco.

Some really useful
information here!

Naughty
Navigation
Content Structure

Nice

When creating the layout for a page really
think about why the user is there and what
they want to find out. Based on that, structure
your content in a way that the most important
parts are the easiest to reach.

ustwo™ studios 2012 / PPP™
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Hi!

…then this

…and finally

Hi!

Hit the link at

link…

this one here.

Hit the link at

the bottom

the bottom

for the info…
Info

What you
Info

Info

were after!

Naughty
Navigation
Minimise Steps

for the info…
Info

Much easier
to get to!

Nice

Although care must be taken not to cram too
much on to one screen, also be mindful that
by introducing too many steps you also create
hassle for your users. Try to make all
information accessible within four pages: any
more can cause frustration.

ustwo™ studios 2012 / PPP™
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Object
Description

Object
Description

Object
Description

Object
Description

Naughty
Navigation
Titles

ustwo™ studios 2012 / PPP™

Title
Object
Description
Object
Description
Object
Description
Object
Description

Nice

Clearly title pages so that the user knows
where they are, and the context of the
information presented to them.
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Title

Title

Object
Description

Object
Description

Lorem ipsum dolor sit

Lorem ipsum dolor sit

amet, consectetur

amet, consectetur

adipisicing elit, sed do

adipisicing elit, sed do

eiusmod tempor incididunt

eiusmod tempor incididunt

ut labore et dolore magna

ut labore et dolore magna

aliqua. Ut enim ad minim

aliqua. Ut enim ad minim

veniam, quis nostrud

veniam, quis nostrud
exercitation ullamco laboris
nisi ut aliquip ex ea
commodo consequat. Duis
aute irure dolor in
reprehenderit in voluptate

Naughty
Navigation
Appropriate Page
Sizes
ustwo™ studios 2012 / PPP™

Nice

Keep your content to an appropriate page size

pages too long though as no one likes to

and try to introduce breaks where it makes

endlessly flick down!

sense. Scrolling through a page is much easier
than linking between them and also reduces
the amount of page requests, which will be
beneficial to mobile users. Don’t make the
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Title

Title

Object
Description

Object
Description

Lorem ipsum dolor sit amet,

Lorem ipsum dolor sit

consectetur adipisicing elit, sed do

amet, consectetur

eiusmod tempor incididunt ut labore

adipisicing elit, sed do

et dolore magna aliqua. Ut enim ad

eiusmod tempor incididunt

minim veniam, quis nostrud

ut labore et dolore magna

exercitation ullamco laboris nisi ut

aliqua. Ut enim ad minim

aliquip ex ea commodo. consequat.

veniam, quis nostrud

Duis aute irure dolor in reprehenderit

exercitation ullamco laboris

in voluptate velit esse cillum dolore eu

nisi ut aliquip ex ea

fugiat nulla pariatur. Excepteur sint

commodo consequat. Duis

occaecat cupidatat non proident, sunt

aute irure dolor in

Naughty
Navigation
Limit Scrolling to
One Direction
ustwo™ studios 2012 / PPP™

Nice

Make sure your content only needs to be
scrolled in one direction – it’s much easier for
the user both physically and mentally, as they
won’t need to pan around trying to keep track
of what they have and haven’t seen.
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•
•
•
•

Pink
Orange
Green
Blue
Naughty

Navigation
Numbered Lists

ustwo™ studios 2012 / PPP™

1.
2.
3.
4.

Pink
Orange
Green
Blue
Nice

If you’ve got more than three or four points in
a list consider using numbers instead of
bullets – these provide some structure which
aids navigation through the content.
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Action
“This is a button that
initiates Action. By
pressing it you will
proceed to the next
screen of the app.”

Naughty
Navigation
Labelling

Action
“Go to next screen”

Nice

Labelling objects in an interface for use with
text to speech functions is an art form in itself!
Labels need to be clear so that users know
what’s going on, but also concise so that they
don’t take too long to listen to.
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7mm2

Naughty
Interaction
Touch Targets

ustwo™ studios 2013 / PPP™

Nice

When designing for touch-based devices it’s

at least a 2mm gap between items so they

important to consider how easy it is to operate

don’t get accidentally pressed. If you’ve got

using fingers and thumbs. We usually base our

components that are intended to be primarily

designs on a minimum touch area of 7mm2,

thumb operated then it’s a good idea to make

which is the rough size of the contact area

those wider, as the average width of an adult

between a finger and screen, and then leave

thumb is 25mm.
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Select Colour
Pink
Enter Colour

Orange
Green
Blue

Naughty
Interaction
Free Text
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Nice

When requesting user input provide default
values rather than just free text entry as it will
reduce the chance of input errors.
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Action

Naughty
Interaction
Buttons and
Hyperlinks
ustwo™ studios 2012 / PPP™

Action

Nice

Buttons are the commonly used method of
initiating actions in applications, so if you opt
for hyperlinks instead you’ll confuse the user.
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This is not
a link

Naughty
Interaction

This is not
a link

Nice

And talking of hyperlinks don’t underline text
that isn’t a link as again this will cause
confusion – users may think something is
wrong when they tap and nothing happens.
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Loading

Naughty
Feedback

Nice

You should always let the user know what’s

notify them rather than revert back to a

going on when they’re in your app. If they

previous screen.

perform an action that needs some processing
or uploading time then show a spinner rather
than simply freeze the screen so they know it
hasn’t crashed. Similarly, if an error occurs
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Alert

Naughty
Feedback
Multi-sensory

Nice

Provide feedback in multiple forms where
possible. For example, relying solely on sound
for an alert would mean that deaf users, or
those located in noisy environments, wouldn’t
be aware that something has happened which
requires their attention.
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Error code 04 type 11
An error has occurred in
the bus_1234 Library.

Something went wrong!

This problem has caused

But don’t worry, press

a crash in the dynamic

Return to go back to the

states of the system.

previous screen.

Please contact your sys
admin on the IT floor.

Return

OK

Naughty
Feedback
Error Messages
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Nice

If something goes wrong then let the user
know what’s happened in an understandable
way, and then provide them with the option to
navigate back to somewhere useful.
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You work for ustwo

Gyppsy
usthree
London

Naughty
Feedback
Error Proximity
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Gyppsy
usthree
You work for ustwo

London

Nice

When designing forms place the error
messages next to the relevant field rather
than separately – this will help the user
identify the error much more easily.
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Lorem ipsum dolor sit amet, consectetur
adipiscing elit. Fusce pellentesque vehicula
Lorem ipsum dolor sit amet, consectetur adipiscing elit. Fusce pellentesque
vehicula elit sed tincidunt. Nam bibendum tempus tellus ac interdum. Lorem
ipsum dolor sit amet, consectetur adipiscing elit. Sed fermentum sodales orci.
Class aptent taciti sociosqu ad litora torquent per conubia nostra, per inceptos
himenaeos. Pellentesque a nibh nibh, vel dictum risus. Nunc congue vestibulum
nibh non sollicitudin. Donec eget metus leo, eleifend tempus enim. Lorem ipsum
dolor sit amet, consectetur adipiscing elit. Fusce pellentesque vehicula elit sed
tincidunt. Nam bibendum tempus tellus ac interdum. Lorem ipsum dolor sit amet,
consectetur adipiscing elit. Sed fermentum sodales orci. Class aptent taciti
sociosqu ad litora torquent per conubia nostra, per inceptos himenaeos.
Pellentesque a nibh nibh, vel dictum risus. Nunc congue vestibulum nibh non
sollicitudin. Donec eget metus leo, eleifend tempus enim.

elit sed tincidunt. Nam bibendum tempus
tellus ac interdum. Lorem ipsum dolor sit
amet, consectetur adipiscing elit. Sed
fermentum sodales orci.
Class aptent taciti sociosqu ad litora
torquent per conubia nostra, per inceptos
himenaeos. Pellentesque a nibh nibh, vel
dictum risus. Nunc congue vestibulum nibh
non sollicitudin. Donec eget metus leo.

Naughty
Typography

Nice

As mentioned in Pixel Perfect Principles good

keeping text light and legible you’ll help these

typography is vital in digital design, and has a

users navigate easily from one line to the next.

great effect on your product’s accessibility.
The basics of good line length and leading are
always important, especially when considering
users with visual or cognitive impairments – by
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Lorem ipsum dolor sit amet, consectetur

Lorem ipsum dolor sit amet, consectetur

adipiscing elit. Fusce pellentesque vehicula

adipiscing elit. Fusce pellentesque vehicula

adipiscing elit. Fusce pellentesque vehicula

elit sed tincidunt. Nam bibendum tempus

elit sed tincidunt. Nam bibendum tempus

elit sed tincidunt. Nam bibendum tempus

tellus ac interdum. Lorem ipsum dolor sit

tellus ac interdum. Lorem ipsum dolor sit

tellus ac interdum. Lorem ipsum dolor sit

amet, consectetur adipiscing elit. Sed

amet, consectetur adipiscing elit. Sed

fermentum sodales orci.

fermentum sodales orci.

Lorem ipsum dolor sit amet, consectetur

amet, consectetur adipiscing elit. Sed
fermentum sodales orci.

Class aptent taciti sociosqu ad litora

Class aptent taciti sociosqu ad litora

torquent per conubia nostra, per inceptos

torquent per conubia nostra, per inceptos

torquent per conubia nostra, per inceptos

himenaeos. Pellentesque a nibh nibh, vel

himenaeos. Pellentesque a nibh nibh, vel

himenaeos. Pellentesque a nibh nibh, vel

dictum risus. Nunc congue vestibulum nibh

dictum risus. Nunc congue vestibulum nibh

non sollicitudin. Donec eget metus leo.

non sollicitudin. Donec eget metus leo.

Naughty
Typography
Alignment

Class aptent taciti sociosqu ad litora

dictum risus. Nunc congue vestibulum nibh
non sollicitudin. Donec eget metus leo.

Nice

Multiple lines of text should always be leftaligned, as the inconsistent spaces in justified
and centred text can be a problem for users
with learning difficulties. Justification can also
create distracting white rivers running through
the paragraphs.
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Example
Example
Example
EXAMPLE
Naughty
Typography
Formatting

Example
Example

Nice

Keep text formatting as simple as possible so

or paragraphs also makes text more difficult

it’s legible for your users. Serif type is harder to

to read AND LOOKS LIKE YOU’RE SHOUTING!

read for visually impaired or dyslexic users as
it’s styling can obscure the shape of the
letters; similarly italics and underlines add
visual noise. Capitalisation of whole sentences

ustwo™ studios 2012 / PPP™

56

Example
Example
Example
Naughty
Typography
Formatting

ustwo™ studios 2012 / PPP™

Nice

Lastly, avoid moving or blinking text as visually
impaired and dyslexics users can find this very
distracting, and also there are epilepsy issues
to consider with blinking/flashing.
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Exa…
Exa…
Exa…
Naughty
Typography
Truncation
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Example 1
Example 2
Example 3
Nice

Truncate text only where necessary, as it hides
useful content.
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Example

+

Example

Naughty
Typography
Merging Text with
Graphics
ustwo™ studios 2012 / PPP™

Nice

Wherever possible try to keep text separate

preference, which won’t be possible with a

from graphics, and instead implement it at a

fixed graphic.

code level. This will allow any text-to-speech
functions on the user’s device to pick it up and
read it out loud, and also lets the user increase
the size of the text or adjust the colour to their
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Information

Naughty
Colour
Visual Aids

Information

Nice

Using icons and colours as visual aids can help
users identify important content on the page,
or can be used to colour code types of content
or areas in your app, which can be especially
useful to those with cognitive impairments.
Make sure that it is used consistently though!
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Passed
Failed

Naughty
Colour
Don’t Rely on
Colour Alone
ustwo™ studios 2012 / PPP™

Nice

However, don’t rely on colour alone to

of males have some form of colour blindness,

communicate information. Mobile devices can

again having an impact on how well colours

have poor colour contrast and are sometimes

will work.

used in less than ideal lighting situations,
which may mean that colours aren’t visible to
users. It is also worth noting that around 8%
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Naughty
Colour
Alternatives

Nice

If you’re using colour to present information,
such as the bars in a graph, then try to
introduce a secondary method of
distinguishing between them; in this case
patterns have been introduced to the orange
and blue areas.
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Example

Naughty
Colour
Colour Contrast

Example

Nice

Always make sure that text and other
important information has enough contrast
between foreground and background colours,
so it’s still legible for those with some form of
colour blindness or other visual impairment.
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AA
Foreground

AA (Large)

Background

AAA
AAA (Large)

Colour
Colour Contrast
Checkers
ustwo™ studios 2012 / PPP™

There are numerous tools out there which can

you should aim to pass AA standards; AAA is

be used to test your colour contrast. One of

better but needs a lot of contrast, too much of

the most useful is Colour Contrast Analyser

which could have a negative impact on your

which can be found here. There’s also a great

designs. The tests also differentiate between

online checker available here – just pop in the

body sized copy and “Large” text which is 18pt

two colours and away you go! As a minimum

and above (or bold and larger than 14pt).
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Red /
Magenta

Colour
ColorAdd
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Yellow

Blue /
Cyan

White

Black

What would you do if you wanted to describe

subtractive light, you can mix and match

colours, but didn’t want to use text labels?

together to create the whole spectrum – just

Turns out a great solution already exists: Color

as you would with paint or ink. It’s also

Add is a simple system that represents colours

possible to represent light and dark shades by

using symbols. By combining these symbols,

merging these symbols with those for white

representing the three primary colours in

and black.
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Colour
ColorAdd
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Pink

Light
Orange

Light
Yellow

Light
Green

Light
Blue

Orchid

Khaki

Red

Orange

Yellow

Green

Blue

Violet

Brown

Bordeaux

Brick

Dark
Yellow

Dark
Green

Dark
Blue

Purple

Dark
Brown

There’s lots more information on their site,
including some great colouring pencils for
colour blind people!
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Text to
speech

Testing

Text to
speech

Another piece of good practice that applies to

simulators, but of course the real thing is even

accessibility as well! Once you’ve created your

better. Speaking of real things, the best way

product, test out how well it works with

(as always) is to test with people that use

various accessibility features such as black &

these features!

white, zoomed view, and text-to-speech.
These features can often be tested in app
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67

Title
Object
Description
Object
Description
Object
Description
Object
Description

Testing
Colour Blindness
Preview in Adobe
ustwo™ studios 2012 / PPP™

Tucked away in the View > Proof Setup menu
are a couple of options to preview how your
design will look to people with the common
forms of colour blindness – this is a great way
to quickly see if there are any issues with
colours and contrast.
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Title
Object
Description
Object
Description
Object
Description
Object
Description

Testing
Sim Daltonism

Title
Object
Description
Object
Description
Object
Description
Object
Description

Sim Daltonism is a more advanced application

resizable floating window that previews

for checking colour blindness accessibility, and

whatever is underneath the mouse cursor.

can test many variations of the condition.
Rather than being a Photoshop only tool it
works across the entire OS, providing a
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Photoshop + ustwo™
So now that we’ve covered a lot of design principles let’s dive right into
some specifics. Although there’s been a lot of noise made about
alternatives to Photoshop, including budget apps and designing in code,
it’s still our day-to-day tool here at ustwo™ (and across the industry as
a whole), so knowing how to use it well is vital. The following sections
show you some of the processes and techniques that we use here…
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Photoshop:
Colour Profiles

System Settings

To avoid any nasty colour jumps between
Photoshop and Mac OS X the colour settings
need to be set up correctly. First thing to do is
make sure System Preferences > Displays >
Color is set to the device you are currently
using (for laptops this is Color LCD).
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Photoshop Colour
Settings

Next, in Photoshop, go to Edit > Color Settings…
and change Working Spaces > RGB to the
screen specified in your System Preferences.
Also change Color Management Policies > RGB
to Off.
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Photoshop Save for
Web

ustwo™ studios 2013 / PPP™

Additionally, in Save for Web the Convert to
sRGB option needs to be deselected, and
Preview should be set to Monitor Color. Your
colours should now be consistent!
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Color Faker

Although following the previous steps should

way that OS X handles profiles. For an in-depth

set you up for most day to day tasks, there’s

explanation read this article; the long and

one last piece of advice to give concerning

short of it is that you should download Color

profiles: if you’re having trouble with colour

Faker and switch it on!

values in Apple software such as Xcode or
Keynote then it will probably be down to the

ustwo™ studios 2013 / PPP™
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Photoshop:
Pixel Precision

Naughty
Shape Layers

Nice

We love Shape Layers here – our workflow is
almost entirely based on them. Being vectors
they’re completely editable, allowing scaling
and transformation of the shape with no loss
in quality, and are less resource hungry than
Smart Objects or bitmaps. Winner.
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Naughty
Shape Layers
Other Vectors

Nice

Also, try to use vectors for other parts of your

added advantage that the fill will

design where you might automatically use a

automatically scale if the canvas size is

bitmap, for example layer masks, as this will

increased. Nice.

further increase the versatility and speed of
the file. Another related tip is to use unmasked
Shape Layers for backgrounds, which have the

ustwo™ studios 2012 / PPP™
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Naughty
Shape Layers
Performance

Nice

As an illustration of the performance hit that

takes up around five times the amount at

bitmaps create take a look at the two values

1.27Mb! By using vectors for everything

highlighted above. These are document size

possible on a large file you can save yourself

readouts for the layers featured on the

hundreds of megs of memory.

previous page: the vector design only uses
260Kb of memory, but the all-bitmap version

ustwo™ studios 2012 / PPP™
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Layer Effects

Another thing we love here are Layer Effects,
so we try to create as much styling as possible
using them. The effects are completely
editable, can be scaled in ratio to their
underlying shapes, and can be quickly copied
and pasted to other objects.
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W : 80 px
H : 80 px

Some Text

Info Panel

As well as using the measurement readout

values that will allow you to quickly check

when drawing vector shapes or using the

consistency throughout a design.

marquee tool to get some super pixel
precision, there is also the Info Panel for extra
detail. Not only does it show measurements
but it can also display colour and opacity
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Snap to Pixel Grid

With Photoshop CS6 there is a global option to
snap vectors to pixels in the Preferences –
make sure Snap Vector Tools and Transforms to
Pixel Grid is selected (it’s on by default). Much
easier knowing that every Shape Layer you
draw will automatically be pixel precise!
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Snap to Pixel Grid
Actions

ustwo™ studios 2013 / PPP™

There may be times when you’d like to alter

Action, assign a Function Key shortcut to it,

Shape Layers on a sub-pixel level, in which

and then record yourself going in to the

case you won’t want them to snap to the pixel

preferences and switching the Snap Vector

grid. If you find you want to toggle the

Tools and Transforms to Pixel Grid option on;

snapping on and off like this quite often then

then record another Action for off. No need to

why not automate it? Simply set create a new

hit the preferences any more!

83

Shape Layer
Options

In Photoshop CS5 Rectangles and Rounded

Rectangle individually as their options are

Rectangles have a built in option to aid pixel

independent of each other.

precision: Snap to Pixels. To access this option
click the drop-down menu to the right of the
shapes in the top tool bar. This needs to be
selected for both Rectangle and Rounded
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Nudging

ustwo™ studios 2013 / PPP™

If you’ve got Photoshop CS5 be careful when

200% though the points will only move 0.5px

using the keyboard to shift points of a Shape

(i.e. half the amount), creating blurred edges –

Layer when zoomed into a design – the nudge

not good. With CS6 pixel grid snapping the

amount varies according to the zoom factor.

points will move 1px no matter what level the

To guarantee a 1px nudge, zoom out to 100%

zoom is; you’ll need to switch off the snap to

and press the arrow key once. If zoomed in at

move by smaller increments though.
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Snapping

Photoshop has lots of handy tools to help with

helps with alignment. The Snap To submenu

pixel precision. One of the first things to do

shows the various items that Photoshop can

when setting up the program is to enable

use for snapping.

snapping – go to View > Snap and make sure
it’s on. Now your objects will snap to other
items and guides on the canvas, which really
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Alignment &
Spacing
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As with most graphics applications Photoshop
has align and distribute tools – find them in
the Layer > Align and Layer > Distribute menus.
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Grids

Sometimes it’s useful to have a grid on screen

Go to Photoshop > Preferences > Guides, Grid, &

when creating a layout. The example above is

Slices… to set yours up.

using 10px gridlines with 10 subdivisions,
which makes it easy to count pixel dimensions
and stops the grid from becoming visually
overpowering when used.
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Some Text

GuideGuide
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To help automate the creation of guides

widths, or if you’ve already sussed these out

there’s a free Photoshop Extension available

on a scrap of paper you can just input all the

called GuideGuide; once installed it can be

values and get your guides inserted

found in the Window > Extensions menu. By

automatically. There are tooltips for each of

varying the data you enter it can work out

the input box icons to let you know what each

measurements such as column and gutter

one does.
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90°

drag to new
document

120°

Global Light Default
Angle
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This is one of those little things that

see in the images above this can mess up the

Photoshop will catch you out on if you’re not

design. To help prevent this from happening

careful. If you’ve set up a design with a

too often you can change the default to a

custom Global Light direction, then drag an

more commonly used angle like 90°. Close all

element from it to a new document, it will

files and then go to Layer > Layer Style > Global

take on the default 120° instead. As you can

Light… to alter the default value.

90

Some Text

Live Previewing

Some Text

Test, test, test again, and then test some

and copy them across to the phone or any

more! One of the best things you can do for

faffing like that. A couple worth checking out

your designs is look at it on the device(s) it’s

are Skala Preview for iOS (and now Android)

going to end up on. There’s lots of software

and Android Design Preview for, you guessed

out there now which will live preview straight

it, Android.

out of Photoshop, so no need to save out files
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Photoshop:
Techniques

Some Text

Naughty
Object Colours

Nice

It’s a good idea with Shape Layers and text to

will make finding the object easier in the

change the colour using the object’s own

Layers palette. As an example: in which panel

setting instead of the Color Overlay Layer Style.

above is the blue square easier to find?

The benefits of this are a) it’s quicker to
update the colour later on as there’s no need
to load up the Layer Style window, and b) it
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Some Text

Naughty
Object Gradients

ustwo™ studios 2013 / PPP™

Nice

The same applies to gradients – use a gradient
fill layer instead of a Layer Style if possible.
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Object Gradients
Dither

Whichever gradient method you use make
sure the Dither option is selected. This will help
smooth out the colour transition and prevent
banding of the colours. With Photoshop CS5
you can only apply a dither to a gradient layer,
but in CS6 you can use it on both.
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Naughty
Concise Layer Styles

Nice

Try not to spread Layer Styles across different
layers, it’s much better if they’re all on one if
possible – keeps things tidy and makes it
easier to copy styles around between objects.
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Scale Layer by 200%

Scale Effects by 200%

Scale Layer Effects

ustwo™ studios 2013 / PPP™

Although you can choose the Scale Styles

with it, but you can use the Scale Effects…

option when you resize an entire document

option to change them as well – although

through Image Size… there are times when

you’ll need to know the percentage increase/

you want to scale individual objects and their

decrease of the original shape to get the two

Layer Effects. When you resize one of these

to match. You can find this option by right-

objects the styling doesn’t automatically scale

clicking the fx icon on the relevant layer.
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Layer Style Strokes
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At first glance it may seem that the only way

outlines. The Stroke will always appear on top,

to create a stroke with Layer Styles is the

followed by Inner Shadow and Inner Glow on

Stroke option, but in fact there are multiple

the inside, and Outer Glow and Drop Shadow

ways to add them to a single shape. If you use

on the outside. Downsides? At thicker widths

the Inner/Outer Glows and Shadows, and set

they can blur, and the Choke can cause rough-

their Choke to 100%, you can also get solid

looking rounded edges.
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Naughty
Layer Style vs.
Vector Strokes
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Nice

If you want the absolute best quality strokes,

rounded, square, or bevelled edges, as well as

and you’re using Photoshop CS6, then add a

dashed outlines. Another useful feature is that

vector stroke directly to your Shape Layer

they can be scaled to half pixels, so if you’re

rather than as a Layer Style. Not only are they

designing for iOS you can set a non-Retina

better quality (more noticeable at thicker

stroke to 0.5px which will then scale up to 1px

widths), but you have the option to use

when the size is doubled for Retina.
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Corner Editor

One feature that Photoshop could really do

above from File > Scripts > Corner Editor, and

with is being able to edit a corner radius after

change the radii value – you can even have

you’ve drawn a Shape Layer. Fortunately

different sizes for each corner. There’s also the

there’s a script out there that solves this

option to use different styles, so you’re not

problem: Corner Editor. With it installed you

just limited to rounded corners.

can select a Shape Layer, bring up the window
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Complex Vectors

For complex vectors the best solution is to use

joke, outline the stroke”. If the vector is more

Illustrator then copy and paste into Photoshop

than just a shape, for example a full colour

(using Shape Layers). Outline any strokes in

Windows style icon, then it will have to be

the Illustrator original, otherwise they won’t

pasted as a Smart Object.

import to Photoshop properly. Remember by
reciting this phrase to yourself: “Don’t be a
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Naughty
Pasting From
Illustrator

Nice

One quirk of pasting in a Shape Layer from

quick look to see if this has happened, and if it

Illustrator is that it sometimes shifts the

has shift the shape back by half a pixel to its

object off-centre by 0.5px in either or both

intended position.

axes, resulting in blurred pixels (although with
the new CS6 pixel snapping options this seems
to be less of an issue now). Always have a
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Naughty
Blending Modes

When creating effects remember to only use

blending effect disappears and it becomes a

blending modes on items which will later be

solid white to black gradient.

merged with other layers. In the example the
Highlight layer will be exported as a separate
asset, but when shown on its own the
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Nice
Blending Modes

The best solution is to recreate the effect
using a layer that is independent of what is
beneath it.
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The original line of text

Replacement text

Naughty
Text Alignment

The original line of text

Replacement text

Nice

When adding text make things easier for
yourself in the future by matching the
paragraph alignment to that in the design, so
text that is supposed to look left aligned has
this setting as well. If you then have to change
the text it will still have the correct alignment.
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Naughty
Paragraphs

Nice

If you’ve got a paragraph of text then use a
text box instead of manually adding line
breaks as they all have to be reset when text is
changed or the typeface altered. With a text
box though the text will wrap automatically,
and the paragraph can easily be resized. Yay!
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Convert to
Paragraph Text

Fortunately Photoshop gives you the option to

options. For Photoshop CS5 these functions

convert between freeform and boxed text, and

are found in the Layer > Type > menu.

vice versa, by selecting Type > Convert to
Paragraph Text or Convert to Point Text, or right
clicking on the layer and selecting the same
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Naughty
Hyphenation
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Nice

Most devices don’t support hyphenation so
you might as well switch it off.
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Naughty
Leading

Nice

When adding paragraphs of text Photoshop
will default to an automatic amount of
leading, which is usually a bit too tight. Make
your text easier to read by manually changing
this amount – in the example the leading has
been changed from (Auto) to 20pt.

ustwo™ studios 2013 / PPP™

109

Crisp
Text Anti-aliasing

None

Sharp

Strong

Smooth

There are a few different types of anti-aliasing

For mockups of text on a device have a look

in Photoshop which can be used to get the

through the various methods and see which

best legibility from text – play around with the

one is closest to how it appears on-screen.

settings to find the most suitable one.
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Some Text
Some Text
Some Text
Some Text

Naughty
Lists

Nice

In some cases when creating lists, particularly

each one. This makes it easier to align and

those with graphics next to them, it’s better to

space everything correctly.

put all the descriptions into one single text
object and set the leading to match the item
spacing, rather than using separate layers for
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Some Text

Some Text

Quick Preview

The screens on mobile devices often have a

Depending on the density of the screen you

higher pixel resolution (PPI) than that of a

may have to zoom out to 50% or even 33% to

typical computer display, so you need to make

see the size of things in real life, and if they’re

sure you don’t create buttons and text that

too small make ‘em bigger!

are too small to use.
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Photoshop:
Organisation

Layers Panel
Options

Is there anything more annoying than the

Add “copy” to Copied Layers and Groups. Every

“copy” that Photoshop adds on to every

little helps.

duplicated layer?! Remove that and some
other visual clutter by going to the Layers
Panel Options and switching off Use Default
Masks on Fill Layers, Expand New Effects and
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Some Text

Naughty
Naming Layers

Nice

Don’t be selfish, give your layers proper

name as they’re created, which is much easier

names! It makes life a lot easier for the next

than trying to do them all at once later on.

person who has to work on your designs, and
you’ll look amazing if the file gets sent off to a
client. A good technique is to give each layer a
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Some Text

Naughty
Ordering Layers

Nice

If you really want to make your files super
special then order the layers nicely as well. A
logical way is to follow how the objects appear
in the design from left to right, top to bottom,
just like reading a book (apologies if your first
language goes in another direction!).
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Some Text

by Name
Search

by Kind

Photoshop CS6 now has a search feature

useful if you want to see all your text for

within the Layers panel, which coupled with

example. There’s lots of other methods in

good organisation can make layer navigation

there including Effect and [Layer] Colour, so

a breeze. Using consistent naming across the

have a play and see what systems you can

board will allow you to search for layers based

come up with to filter and work on your layers.

on their name, or you can filter by kind –
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Grey (“neutral”) used for
reference items, for example
wireframes or screenshots

Red (“danger”) for old,
unused elements
Popup window

Green here to show different
states of the same button

Core design doesn’t
use colour labels

Colour Coding

Here’s an example of how colour coding in the
Layers panel can make it easier to navigate.
Right click on the show/hide control to bring
up the layer colour menu.
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Naughty
Expanded Layer
Effects
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Nice

Like a messy house guest, expanded Layer
Effects can make it harder to find your way
around. Keep them collapsed and things are a
lot better.
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Naughty
Delete All Empty
Layers

Nice

Try not to leave empty layers or layer groups
scattered throughout your files as they add
unnecessary clutter. There’s a handy script
located in the File > Scripts menu called Delete
All Empty Layers, which does exactly what it
says on the tin!
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Naughty
Locked Layers

Nice

Locking layers is a great way to preserve an

preventing you from moving or deleting the

object when working on a file, but try to make

group can get really frustrating!

sure that they’re unlocked when handing over
to other designers. Digging through layer sets
trying to find the rogue locked layer that’s
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Layer Comps

Some Text

Some Text

Some Text

Some Text

Some Text

Some Text

Layer Comps: so close, yet so far. What could

working on a design. Best created once your

be a great way to show multiple variations or

document is XXXX_Final_Finished_Finito.psd.

layouts in a file is held back by the fact that
changing anything once they’re set screws
them up, so you can’t really use them whilst
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Photoshop:
Export

Asset Files

ustwo™ studios 2013 / PPP™

Using our ustwo™ Crop & Export scripts (see

an asset name; each group can contain as

next page) we’ve tried to make the asset

many layers as you want as the scripts work

export process super easy. The first thing to do

on everything at the root level. Also if you lay

is set your files up properly for them to work:

everything out separately as shown, rather

put every individual object that you want to

than stacked on top of each other, you’ll end

export within its own layer group and give it

up with a useful asset reference sheet.
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Export Scripts

We’ve built some awesome Photoshop scripts

margin added around each edge so that it will

that will run through a file and export all the

work correctly in Flash. File naming works as

individual assets as PNGs…no muss, no fuss.

with the normal Crop & Export.

Just copy them from Scripts to your Adobe
Photoshop CSx/Presets/Scripts folder, (re)start

ustwo™ Crop & Export +1px [layername]

Photoshop and you’re good to go! There are a

Same as above, using the alternative naming

few variations:

method.

ustwo™ Crop & Export [filename]

There are also a couple of additional scripts

[layername]

available which won’t crop the layers but will

This will crop to each asset and then export

instead stick to the dimensions of the

the file as [filename][layername].png, so with

Photoshop file. This can be useful for things

a file called button.psd, and layer called

like screen comps where the actual content

_normal the exported asset would be called

might change size, but you want all the

button_normal.png.

exported PNGs to have the same dimensions.

ustwo™ Crop & Export [layername]

ustwo™ Export [filename][layername]

Same script as above except in this case the
filename is not added to the exported asset,

ustwo™ Export [layername]

only the layer name is used. For the example
above the exported asset would be called
_normal.png.
ustwo™ Crop & Export +1px [filename]
[layername]
In this case the exported asset will have a 1px
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Save for Web

Check out the differences in file size of the two
different PNGs here – Save As… has created a
file that’s 26KB bigger than Save for Web. Well
worth using the latter then!
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Reducing File Size

Everyone’s happier when file sizes are kept
down, so if you have an asset that doesn’t
need transparency try converting it to an 8bit
PNG. In the example above there’s no loss in
quality from making the switch, but the file
size has been almost halved.
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ImageOptim

If you want to shave a few more KB from your

as comments and colour profiles, as well as

exported file sizes then give ImageOptim a

optimising the compression used. As a side

whirl – simply drag and drop your files onto its

note if you’re developing for iOS then it might

window and watch as it works its magic. The

now be worth using ImageOptim as this

app works on PNG, JPEG and GIF images by

article explains.

stripping out any unnecessary metadata such
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Reducing
Photoshop File Sizes

A quick way to shave some of the size from

want to keep things small. Zipping the file

your PSDs is to switch off the visibility of all the

afterwards also dramatically reduces the size.

layers. Not always practical if a design requires
a certain combination to be shown, but it can
be useful if sending or uploading files and you
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565
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Some devices don’t support all the colours

depth change from 24bit (8+8+8) to 16bit

that you can see on your computer screen,

(5+6+5) (16.7 million to 65536 colours, a

which can cause visual degradation of your

commonly supported amount on mobile

assets. To prevent this from happening convert

screens); to counteract the reduction in

them to 565 images using the Ximagic

colours the filter also applies dithering, which

ColorDither SP plugin. 565 refers to the colour

will prevent banding in any gradients.
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565
Batch
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The best way to apply 565 dithering to

(rather than Save and Close in the Destination

multiple files is to create a Photoshop Action

menu which will increase the file size). The

and use the File > Automate > Batch tool.

action shown is included in Actions/PPP™.atn;

Export all the assets normally using one of the

you’ll need to create a folder called export on

Crop & Export scripts, then set up an Action to

your Desktop for the processed files to be

apply the filter and export using Save for Web

saved in.

131

Photoshop:
Tips

No Glow

Glow
Strokes

Strokes with a 1px thickness can look a little
too thin on curved shapes (straight edges are
fine though), so to strengthen the stroke
without making it bigger also add a Glow
using the settings shown. The difference is
subtle, but it definitely helps.
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Fading Circles

Circular fades are really useful for loading
icons and can be created easily with the Stroke
Layer Style. The trick is to set Fill Type: Gradient
and use Style: Angle.
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Quick Shine

You can create a quick shine effect using a
white inner shadow with a low Opacity value.
Be careful though as the shape of the shine
will follow that of the top edge of the layer it is
applied to, so it tends to work best with
rectangular or near-rectangular objects.
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Add Noise with
Inner Glow
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You can quickly add a simple noise texture to
an object using the Inner Glow Layer Style. Set
the Source to Center, Size to 0, then vary the
amount using the Noise setting.

136

Flat logo merged to a white background

Image > Adjustments > Invert
Then Select All and Copy

Add a colour layer, add a layer mask, alt-click
Image > Adjustments > Desaturate

on the mask and then Paste. This will create
a mask from the black and white logo image

Image > Adjustments > Levels
Use the black point picker to select
the main grey colour

Extracting Logos

You now have a logo on a transparent
background

Sometimes it can be difficult to obtain a

download: they’ll often have logos in them

decent vector logo, in which case a last resort

which can then be opened in Illustrator.

is to extract one using this process. Another
useful tip is to search a company’s site to see
if they have any PDF documents available for
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Star Fields

Have a play around with the settings in the
Brushes panel to create some different brush
effects, like a basic star field for example. By
increasing the Size Jitter and Opacity Jitter the
brushes become more random.
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Patterns
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Add a little something to your designs by

can then be used throughout Photoshop,

including a pattern or texture. They’re easy to

including the Layer Style panel. Experiment

make using the Pattern tool: first draw a tile

with Blend Modes and Opacity to alter the

that can be repeated smoothly, drag a

pattern’s look (black and white work well as

selection around it, then go to Edit > Define

they are neutral colours and will work with any

Pattern… to add it to the presets. This pattern

underlying design).
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Kuler

Feeling a bit uninspired when it comes to

It’s an incredibly useful tool for creating colour

colours and palettes? Then give Kuler a go! It’s

schemes or finding a bit of inspiration.

an online service where users can create and
browse through colour palettes, but there’s
also an extension for it so you don’t even need
to leave Photoshop.
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Shortcuts
Paths

There are loads of shortcuts for the path tools

alternatively - or Alt will subtract from the

to make working with them quicker. If you’ve

shape. Once you’ve drawn the second path

got two existing Shape Layers you can

you can then quickly subtract and add it from

combine the paths using Command + E. After

the other by selecting it and pressing - or +.

drawing a path you can add another to it by
pressing + or by holding down Shift;
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Some Text

Shortcuts
Paths

If you’re editing a path with the Direct

Command + Shift + H will hide the current path

Selection Tool and you don’t want to

you’ve got selected - useful if you want to

accidentally select other Shape Layers in the

preview the shape without the path obscuring

document then tap Q to enter Quick Mask

the edges.

Mode, which will isolate the one you’re
currently working on.
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Shortcuts
Selections &
Brushes
ustwo™ studios 2012 / PPP™

When creating a selection hold down the

Use the square bracket keys [ and ] to adjust

Space key to move it around before letting go

brush size up and down. Shift plus [ or ] will

of the mouse button and fixing the size.

increase the brush hardness.
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Shortcuts
Layers

ustwo™ studios 2012 / PPP™

Select a layer and press the forward slash / key

Collapse or expand all layer sets in a

to lock transparency. On Shape Layers this will

document by holding down the Command key

lock the position instead.

and clicking on one of the triangle icons.
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Shortcuts
Layers
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Hide all other layers by holding down Alt and

To show or hide layers in a row click, hold

clicking on the visibility icon.

down and drag the cursor across all the
relevant visibility icons.

145

Shortcuts
Keyboard

F (Cycle screen modes)

Shift + Arrow keys (Move selection outline)

Switch between normal, fullscreen with task

Moves selection outline by 10px.

bar and full screen with black background.
Command + Arrow keys (Move selection)
Space bar (Hand tool)

Moves selected layer or area by 1px.

Temporarily selects the hand tool while held
down, use to pan around an image.

Command + Shift + Arrow keys (Move
selection)

Command + ` (Cycle open documents)

Moves selected layer or area by 10px.

Acts like Alt + Tab in the OS, changing between
open documents.

Command + Option + A (Select all layers)
Selects all layers in the layers palette.

Space + F (Canvas background)
Cycles through canvas colours.

Command + Click layer thumbnail (Load layer
as selection)

X (Switch colours)

Load layer transparency as a selection

Flips the foreground and background colours.
Shift + Click mask (Enable/disable layer mask)
D (Default colours)

Switch layer mask on and off.

Resets foreground and background colours to
black and white.

Alt + Click mask (View mask)
Show the layer mask as a separate image

Arrow keys (Move selection outline)

which can be edited like a channel.

Moves selection outline by 1px.
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Shortcuts
Keyboard

Command + Click mask (Load mask as
selection)
Loads up the mask as a selection.
Command + Shift + I (Invert selection)
Reverse the current selection so previously
selected areas become deselected and vice
versa.
Command + D (Deselect)
Removes current selection.
Command + Shift + D (Reselect)
Reloads the last selection.
Command + J (Copy layer)
Duplicate the currently selected layer.
1 – 0 (Change layer opacity)
Adjust the selected layer opacity in 10%
increments.
Shift + [+/-] (Cycle blending modes)
Cycle through layer blending modes.
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Keyboard Shortcuts
and Menus

Become a Photoshop lean machine by

Another really useful thing to do is remove the

creating custom keyboard shortcuts using the

Command + Q shortcut to prevent any

Edit > Keyboard Shortcuts… dialog. In this

accidental quits of Photoshop.

example a couple have been created for Align
Vertical and Horizontal Centres.
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Illustrator

Introduction

Illustrator: deploy when Photoshop’s vector
tools just aren’t quite up to the task! We tend
to use it for creating complex vectors which
can then be styled in Photoshop – that way
they retain their scaleability but get all the
visual treats that Layer Effects allow too.
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Illustrator Colour
Settings

It’s worth setting up the colour profiles in

As with its sibling, go to Edit > Colour

Illustrator as well – for example you might

Settings…, make sure Working Spaces > RGB is

want to add some colour to vector sketches

set to the screen specified in your System

which match what you see in Photoshop.

Preferences and Color Management Policies >
RGB is Off.
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Useful Settings

ustwo™ studios 2013 / PPP™

There are a couple of useful settings in

Once this is done the keyboard increment can

Illustrator > Preferences. The first is to set the

be set to 1px, which means the cursor keys

Units to Pixels for General and Stroke, which

can be used to nudge shapes and points

will mean all your dimensions will match up

around while remaining on whole pixel

pixel for pixel with Photoshop.

measurements.
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Grids

Like Photoshop, the Illustrator grid can be set
up in Illustrator > Preferences > Guides, Grid, &
Slices…, again with useful 10px gridlines and
10 subdivisions.
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Snap to Grid
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Yup, you guessed it, stick Snap to Grid on too!
Like Photoshop it’s located in the View menu.
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Smart Guides

Sometimes you need to push the boundaries

have recognised where the two overlap and

and break out of the grid, in which case a good

let you easily add a point where the two

alternative is to use Smart Guides for non-

intersect.

straight/off-grid shapes and points. In the
example above a right-angled triangle has
been placed below a circle; the Smart Guides
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Naughty
Precision

Nice

The Transform window is your pixel precision

the same proportion, keeping the object in

best friend. It can either be used to check a

scale.

whole shape (top row), or a single point
(bottom row). Also, make use of the link
option for the W and H boxes, so when one
value is changed the other will also adjust by
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Align to Pixel Grid

The new super-villain of Illustrator! Make sure

for example. To show the Options go to the

this option is deselected when drawing shapes

Transform panel menu.

– it will align objects on the artboard to the
underlying grid, which can cause unexpected
shifts in the position when strokes are added

ustwo™ studios 2013 / PPP™

157

Pixel Preview On
Pixel Preview

Pixel Preview Off

This is another one to be wary of: when View >
Pixel Preview is on it can show pixels as being
precise when in reality they’re not.
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Preview Blurring

Nothing to worry about too much here, but

appear when the shape is imported into

sometimes Illustrator will show a shape as

Photoshop.

having blurred edges even though the
dimensions are exact in the Transform
window. This seems to be a bug with the
program, but thankfully the blurring won’t
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Organisation

If you tried to name every layer in an
Illustrator file you’d get nothing else done, but
try to organise shapes into groups so you don’t
end up with one massive artboard the size of a
football pitch – not fun to scroll around!
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Appendix

PPPatterns™

There’s a library of patterns available to use in
Patterns/PPPattern™.pat and also ready
applied as Layer Effects in Patterns/
PPPattern™.psd

ustwo™ studios 2013 / PPP™

162

Thanks!

@pppustwo
@gyppsy
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